Excel: größenabhängiges Runden

Manchmal möchte man Werte in Abhängigkeit ihrer Größe runden — also aus 105 EUR sollen 100 EUR werden, aber aus 10.100 EUR eher 10.000 EUR.

Hierzu kann man sich der Logarithmusfunktion bedienen: Steht in A1 die zu rundende Zahl, so liefert =RUNDEN(A1;-LOG10(A1)+1) das Gewünschte. LOG10(A1) — der „Zehnerlogarithmus“ — liefert beim Argument 1 den Wert 0, bei 10 den Wert 1, bei 100 den Wert 2 usw. Die Anzahl,auf die gerundet wird beträgt also bei Zahlen < 10 den Wert 0 (→ Rundung auf die nächste volle Zahl), zwischen 10 und 100 den Wert -1 (→ Rundung auf nächstes Vielfaches von  10) usw.

Möchte man nicht auf volle Werte, sondern auf „halbe Teilung“ runden, so multipliziert man vorab mit 2, rundet dann, und halbiert wieder: =RUNDEN(A1*2;-LOG10(A1)+1)/2

 

Schreiben Sie einen Kommentar

Ihre E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.